Issue Viewing Exported Depthkit Clip In Unity 2020.3

Hello,

I was able to create a Unity 2020.3.33 project with the HDRP pipeline and see the sample autumn data work correctly.

However when I export my clip into Unity, nothing appears. An interesting note is that if I use the autumn meta data, I can see my clip and it does play though it doesn’t play in full

Is there something I should check for in my export settings?

Thanks!

@CameronDonley, sorry to hear you’re having trouble. Here are some questions to help narrow down the issue:

  • Are is your asset a Depthkit Core (single-sensor) or Depthkit Studio (multi-sensor)?
  • When you swap your asset for the Autumn sample, are you swapping only the video, poster, and metadata files linked to the Depthkit object, but keeping all other components and settings in the object the same?
  • Are you using the Shader Graph look, the VFX Graph look, or both?
  • Are you getting any errors in the console?

Screen recordings of what you’re seeing, or even screenshots of your Depthkit object’s Inspector panel may also be helpful in identifying the issue of you are able to share. Let us know, and we’ll see if we can help figure this out.

Hey Cory,

  • I recorded the asset using depthkit 0.6.0 app with 1 Azure Kinect DX Camera
  • I’m using the same prefab Depthkit Clip + Studio Shader Graph Look for both. Here’s me with my meta data

Forum won’t let me have two screenshots in the same post so I’ll make another post with the vs screenshot

  • There are no errors in the console

vs me using her metadata