[RESOLVED] Depthkit Core VFX Graph Texture Source errors with Unity Timeline and AvPro2

Hello there,

So I am using a timeline and avpro to play 17 dk clips in a sequence and for the most part everything is working fine and all of the clips are playing back. However, 7 of them keep giving me this error both in editor and during runtime, and I believe these errors are also responsible for crashing the quest build as well.

The other 10 Depthkit playback objects were doing this at one point as well, and clicking generating data in the “Depthkit Core Visual Effect Graph Texture Source” solved the issue. However, for 7 of them I generate new data and error stops, then in runtime the error comes back and after exiting the play mode the errors persist until I regenerate the data again. As far as I can tell everything is same between the 10 that are fine and the 7 that aren’t, besides position data and the files video/poster/text files being used in the depthkit and avpro scripts, and that when I hit generate data or playback ends, the 10 that work have their DataWidth and Height reset to 0s in the vfx graph, while the 7 that are giving errors have their DataWidth and Height reset to 1s or 256s. I’ve included screenshots of my timeline showing one of the working clips on top and one of the error clips below it if that helps.

I have been able to get around this in playmode with a script that calls the generate function of the Core VFX graph texture source at start for those seven clips, but the issue still persists when in the editor. Any insight into why this is happening would be great and let me know if I can provide any more info! Thanks!


Hi @WhittSellers

This is complex one for sure, thanks for bringing it up. We’ll take a look at reproducing on our side and see if we can address it or have further questions for you.

Hi, @WhittSellers. We think we have identified the cause of this issue, and it should be fixed in the upcoming version of our Unity plugins. We’ll let you know when it’s available.

Awesome, thank you! Looking forward to testing out the new plugin when it is ready!

Any chance you are able to say if the new plugin will be tested with Unity 2022? Would love to start prepping experience with depthkit for the Apple Vision Pro!

Great question! @WhittSellers we are sticking to 2020.3 LTS for this next release. We plan to do a seperate release dedicated to testing 2022 in anticipation of Apple Vision Pro very soon!

1 Like

@WhittSellers following up to ensure you saw that, alongside Depthkit v0.7.0, we also released Phase 9 of the Depthkit Expansion Packages for Unity, which includes the fix we believe applies to your issue. Update the packages in your project and let us know if your issue is addressed.

1 Like

Awesome! I’ll see about updating and let you know soon!

Hey @CoryAllen I’ve upgraded to the new package in one of my projects, but I’m getting a new error now when scrubbing through the timeline and when by timeline loops during playmode/runtime.

I can get it to go away by disabling and re-enabling the depthkit clips in question, but they still comeback from time to time.

Hi Whitt,

Thanks for going through the upgrade path to test the new Phase 9. Sorry to see you are still encountering issues. We haven’t seen this error before, and since there is no strack trace I’m not sure it is directly related to Depthkit

See this Issue in the Issue Tracker

Can you confirm that you are using Unity 2020.3 LTS, which is what we test against? Also if its possible to start a clean project to create a minimal reproduction of the issue so we can see it on our side, that would be really helpful.


Hey James! Sorry for the late reply, I’m in Unity 2020.3.45, and I’ve included a full error log screen cap here as well if that helps.

I’ll see about creating a new scratch project to test as soon as I can as well!

One thing to note, this error is actually happening in a second project I’m working on that doesn’t use AVPro2, only the default Unity video player. I will upgrade the package in my other project that uses avpro2 and let you know how it goes there as well!

@WhittSellers We haven’t been able to reproduce the issue on our side, but after searching around for similar issues in Unity, our team found a thread that seems to indicate that the issue may be resolved by disabling deleting the Depthkit object, and reconstructing it from scratch. If this from-scratch approach solves the issue, this could indicate that it’s related to upgrading the packages in an existing project. Try that and let us know what your results are - Thanks!

Hi @WhittSellers, I was finally able to repro this issue, and it is quite odd. It does seem to be related to disabling / enabling Mesh Source components, and some internal state of the Mask Generator seems to be getting corrupted. I don’t yet have a fix for you unfortunately, but at least I can interrogate the problem now.

As a temporary work around, you may be able to get away with disabling just the Look component, rather than the entire game object if that is what your timeline is doing now.

Thank you @Tim for continuing to investigate! I Tried your suggestion and that appears to have fixed it for now! However that was just in one project, the one I’ll see about upgrading the plugin in the project this started with and report back on that next.

@WhittSellers - I have emailed you a patched version of the Depthkit Expansion Packages for Unity. Please test these out and let us know your results.

For anyone else, we are performing some additional internal testing, and will have this patch available to download from our website soon.

Followed up via email, but tested the patched version today and it appears to have solved my issues both in editor while scrubbing the timeline and in playmode, and in executable builds on both PC and Android! Thank y’all so much!

1 Like