Issue with OBS and WebRTC

I’m using Depthkit Studio for a project and I’m testing how to use it with WebRTC. I’ve followed the tutorial for WebRTC and OBS (Livestreaming) and everything worked fine until I tried to put the metadata file in Unity.

Here there are a couple of images of what is happening. Only one because the system doesn’t allow more than one the first time… :frowning:

The computer is an MSI Creator 15 and I’m using Unity 2019.4 LTS with Depthkit, OBS, and the rest of things for the process.

Any idea?



Hi @JavierCampos
Sorry to hear of the trouble with WebRT and OBS

Can you please share a screenshot of your Unity GameObject where Depthkit components are configured?

It may be the case that you are using Depthkit Core Mesh Source instead of Depthkit Studio Mesh Source, or that the metadata is not configured correctly.

Also please share a screenshot of your OBS configuration.


Sure! I’ll do it asap.


@JavierCampos Another item to check is the resolution of your Livestream - This is unlikely to be a standard resolution like 1920x1080p, so you will have to set your OBS (see below) and WebRTC transmitter to match the resolution of the Livestream. The Livestream resolution can be found at the very bottom of the livestream_meta.txt metadata file.

Perfect! I’ll try!

Thanks for your support!


Hi Cory and James:

Sorry for the delay… I’ve solved it. The issue is that in the receiver, in OBS Browser Windows, if I put in the sender 2064x1150, in the receiver, I have top ut 1150x2064 and then it goes ok.

Anyway, I’ll try to send you more details, because I have some problems understanding about Spout and OBS because the structure of the 5G project.

I’ll write you asap.

Thanks for your support!


Hi @JavierCampos - glad you are making progress. Let us know your next set of questions around Spout, happy to help