Alpha 8 MeshSequence package install error - Solved

Hi, I get an error when installing the package, maybe missing some dependencies? I followed instructions:

In Unity, create a new project with the 3D preset (Built-in Render Pipeline).

In Package Manager , import the following Depthkit packages in this order:

  1. depthkit.core
  2. depthkit.streamingimagesequenceplayer

And I get error in red after adding the meshsequence package:

C:\Apps\Depthkit\Depthkit_Studio_Expansion_Package_Phase8_Alpha_112421\Phase8_rc1\\Runtime\GeometrySequenceExporter.cs(304,46): error CS1061: ‘Texture2D’ does not contain a definition for ‘GetPixelData’ and no accessible extension method ‘GetPixelData’ accepting a first argument of type ‘Texture2D’ could be found (are you missing a using directive or an assembly reference?)

Using Unity 2019.4.13f1


Hi Damian,

We have only tested the new Geometry Sequence Phase 8 in Unity 2020.3 LTS. Is it possible for you to give it a try there to see if the same error pops up?

1 Like

It installed ok on 2020.3! thanks James!