Azure Kinect Sensors not picking depth

I have a sensor on my setup that is only picking half of the depth (as shown in attached screenshot), while the setting are the same for all 5 sensors. Is this this a setting issue or it has to do with the sensor itself?

I’ve checked the sensor on the Azure Kinect Viewer and I see that it is picking the depth… but on the Depthkit it’s only half.

@Telmo Interesting - The only time I have seen the depth data degrade like this is if there’s an object that’s physically close to the front of the sensor, which may reflect the ToF pulses right back into the sensor and “blow out” some areas of the frame.

Is it possible that the sensor’s depth receiver (the circle in the center of the face of the Azure Kinect) was partially occluded? This would not have an effect on the RGB image, since that sensor is offset.

Is the missing depth data flickering at all? Can you share a screen recording of that capture playing back, as well as one from a different angle where the color and depth data are complete?

You can view the screen recording of the capture here:

@Telmo From what I can see in your video, there are a couple of factors contributing to the loss of depth data here:

What model of light fixtures are these? From the amount of degradation of the depth data on the floor, it looks like there may be a lot of stray infrared energy in the room - We often see this when halogen “hotlights” are used, as they emit a ton of infrared energy which can interfere with the sensors. More information about compatible lighting is available here.

Your subject pants in particular also appear to be degraded in the other sensors. This could be in-part due to the stray infrared light reflected off the floor, but also may be the way that the fabric reflects the signal from each of the sensors. You can learn more about material constraints here.

My recommendation is to try the following:

  • Create a new capture while toggling the lights off and on to see if the quality of the depth data changes. If the lights are causing issues, I would expect to see the depth map become more solid/complete/stable when they are turned off.
  • Mitigate any floor reflectance by laying down a soft chromakey material on the floor like chromakey fleece.
  • Have your subject try a couple different wardrobe options to see if the fabric material is causing issues.

Let us know what your results look like. Thanks!