Cannot run free version of Depthkit


I just downloaded the free version of Depthkit and installed it, but after I tried to run it, it shown CMD log and the main software cannot be opened. When try to uninstall it and it still error…

CMD log

Depthkit v0.6.0 build 11-#73de
2022-10-20 23:53:00.822 INFO [3540] [Depthkit::LogSystemInfo@14] ====================================================
2022-10-20 23:53:00.991 INFO [3540] [Depthkit::LogSystemInfo@15] Depthkit System Information
2022-10-20 23:53:00.992 INFO [3540] [Depthkit::LogSystemInfo@16] ====================================================
2022-10-20 23:53:00.993 INFO [3540] [Depthkit::LogSystemInfo@29] CPU Manufacturer: Intel
2022-10-20 23:53:00.993 INFO [3540] [Depthkit::LogSystemInfo@30] CPU Model: Intel(R) Core™ i7-9750H CPU @ 2.60GHz
2022-10-20 23:53:00.994 INFO [3540] [Depthkit::LogSystemInfo@31] Number of logical CPU cores: 12
2022-10-20 23:53:00.995 INFO [3540] [Depthkit::LogSystemInfo@32] Total System memory (MB): 16233
2022-10-20 23:53:00.995 INFO [3540] [Depthkit::LogSystemInfo@34]
2022-10-20 23:53:00.996 INFO [3540] [Depthkit::LogSystemInfo@52] GPU Manufacturer: Nvidia
2022-10-20 23:53:00.996 INFO [3540] [Depthkit::LogSystemInfo@53] GPU Model: NVIDIA GeForce RTX 2060/PCIe/SSE2
2022-10-20 23:53:00.997 INFO [3540] [Depthkit::LogSystemInfo@54] GPU Driver version: NVIDIA 512.78
2022-10-20 23:53:00.997 INFO [3540] [Depthkit::LogSystemInfo@55] Total Dedicated GPU memory (MB): 6144
2022-10-20 23:53:00.998 INFO [3540] [Depthkit::LogSystemInfo@57] ====================================================

@pennySH , sorry to hear you’re having trouble launching Depthkit.

It appears that Depthkit is crashing shortly after launch - Is this correct? If this is the case:

  • Launch Depthkit from the command line by opening a Command Prompt window and typing in the location of the Depthkit app executable. (e.g. C:\Program Files\depthkit\depthkit.exe)
  • When Depthkit crashes, the console will be preserved in the Command Prompt window.
  • Copy the entire contents of the Command Prompt window, and post them here.

We’ll see if we spot anything in the console log that helps diagnose the issue.


yes, Depthkit crashes, the all console log is the same as before.

D:\02_program\depthkit> depthkit.exe
Depthkit v0.6.0 build 11-#73de
2022-10-26 10:49:03.259 INFO [18076] [Depthkit::LogSystemInfo@14] ====================================================
2022-10-26 10:49:03.260 INFO [18076] [Depthkit::LogSystemInfo@15] Depthkit System Information
2022-10-26 10:49:03.260 INFO [18076] [Depthkit::LogSystemInfo@16] ====================================================
2022-10-26 10:49:03.261 INFO [18076] [Depthkit::LogSystemInfo@29] CPU Manufacturer: Intel
2022-10-26 10:49:03.261 INFO [18076] [Depthkit::LogSystemInfo@30] CPU Model: Intel(R) Core™ i7-9750H CPU @ 2.60GHz
2022-10-26 10:49:03.261 INFO [18076] [Depthkit::LogSystemInfo@31] Number of logical CPU cores: 12
2022-10-26 10:49:03.261 INFO [18076] [Depthkit::LogSystemInfo@32] Total System memory (MB): 16233
2022-10-26 10:49:03.261 INFO [18076] [Depthkit::LogSystemInfo@34]
2022-10-26 10:49:03.261 INFO [18076] [Depthkit::LogSystemInfo@52] GPU Manufacturer: Nvidia
2022-10-26 10:49:03.261 INFO [18076] [Depthkit::LogSystemInfo@53] GPU Model: NVIDIA GeForce RTX 2060/PCIe/SSE2
2022-10-26 10:49:03.261 INFO [18076] [Depthkit::LogSystemInfo@54] GPU Driver version: NVIDIA 512.78
2022-10-26 10:49:03.262 INFO [18076] [Depthkit::LogSystemInfo@55] Total Dedicated GPU memory (MB): 6144
2022-10-26 10:49:03.262 INFO [18076] [Depthkit::LogSystemInfo@57] ====================================================



Cory Allen via Depthkit Community <> 於 2022年10月26日 週三 清晨5:28寫道:

@pennySH It looks like there aren’t any errors being reported in the log. Can you provide more information about the computer?

  • What version of Windows is installed?
  • Is the computer running in a virtual environment?

@CoryAllen here is more information about my computer and it isn’t running in a virtual environment. I had tried installing in C drive and still not work…

Intel(R) Core™ i7-9750H CPU @ 2.60GHz 2.59 GHz
64-bit operating system, x64-based processor

Edition:Windows 10 Home
Installed on : 8/‎6/‎2021
OS build:19043.2130
Experience:Windows Feature Experience Pack 120.2212.4180.0

I have encountered the same problem in the past.
This is a temporary fix, but you can try creating a new local account on your Windows and logging in.
The depthkit might work.

My past post

@satorukoshiba, thanks for sharing your experience, and for the recommendation.

@pennySH, some other things to try are:

  • Disabling any virus protection or network firewalls on that computer to see if Depthkit is able to start.
  • Disconnecting your computer from all networks.
  • Test on another PC is you have one.

@pennySH Have you tried the troubleshooting steps listed above? Are you still experiencing this issue? If not, let us know so we can close the ticket. Thanks!