Failed to create Compute Buffer UAV, HRESULT: 0x80070057

Hello everyone,

I recently got on the studio pilot license and now I am trying to import footage into Unity and show it in the scene, but I get the following errors:
Failed to create Compute Buffer SRV, HRESULT: 0x80070057
Failed to create Compute Buffer UAV, HRESULT: 0x80070057

Project information:
I’m on unity 2019.4.8f1 and I’m using the built-in render pipeline. I also tried it in URP.

Steps I’ve taken:
I imported the footage (mp4, metadata and poster png)
I imported the Depthkit Core, Depthkit Studio packages and the samples that come with it.
I dragged Assets/Samples/Depthkit Studio/0.5.1/Prefabs - Depthkit Studio Built-in RP/Depthkit Clip + Studio Built-in RP Look.prefab into the scene and setup the video clip, meta data and poster.
I thought this should be enough to show the clip in the scene, but when I run it, I get the errors mentioned above and nothing shows.

Anybody got any idea what this is about?

Hi Mike,

Sorry for the delay! This issue is occurrs when the bounds are too large on the Depthkit Unity Studio Mesh Generator. This can be addressed by either reducing the volume density so the same bounds space takes up less data.

Alternatively if you do not need the bounds to be very large, you can use the handles on the faces of the bounds to reduce the volume to just contain your clip’s action.

It’s often the case that if the depth ranges were not set in Depthkit the default bounds will be very large.