[RESOLVED] After Effects can´t import OBJ sequences

By following the tutorial ( Using Depthkit OBJ Sequences with Depthkit Core, After Effects and Plexus ) and getting to the part of importing the OBJs as 3D files for plugins. After Effects tries to import the sequence, but it always gives me the same error.

I also tried with OBJ as 3d for Trapcode plugin and the same thing happens.

The only way that has worked for me so far is using Video Copilot’s Element 3D plugin. But it is somewhat limited in the options for working with particles.

Will it be a problem with After Effects 2024? or is there something in the way of exporting that is not working?
Cap error import

@aldomanetti Sorry to see you’re experiencing this. I just tried reproducing the issue on my end, and I am able to load Depthkit OBJ’s into After Effects.

When importing, are you selecting the OBJ’s themselves as pictured below (as opposed to selecting the containing folder)?

Are you able to share the assets you are having trouble importing?

Thanks a Lot, i iwll try this technique.

Meanwhile i share with you a work in progresss…



@aldomanetti Thanks for sharing - Nice work!

Do keep us up to date with this issue. One possibility which would cause the files to fail to open in After Effects is is that the OBJ’s were exported out of a previous version of Depthkit with corrupted OBJs. You can confirm if this is the issue by opening one of the OBJ’s in a text editor and checking to see if the numbers are formatted with commas (incorrect) instead of periods (correct). This has been resolved in the latest release of Depthkit, so if this is the issue with your OBJ files, you can simply update Depthkit to the latest version, and re-export the OBJ files.

@aldomanetti Are there any updates on your end? If you are still experiencing this issue, please share a sample of the OBJ files you are trying to import into After Effects - If not, let me know so I can close the ticket. Thanks!

Hi Cory
I’m sorry but I’ve been looking at other projects and I haven’t taken the time to review what I have pending. I hope to see it tomorrow and I’ll give you feedback.

I did the import tests and it doesn’t work, I recorded a video so you can see what’s happening to me.
The way it worked for me is to import but only within the Element 3D Plugin, but with it I lose the features of the new after effects engine. And I can import Obj but only as separate elements, not as sequences.

I think it worked for me once, I don’t remember well. But I think that by passing the exported DepthKit sequence through Cinema4d and from there re-exporting the OBJ sequence. But like I said, I’m not 100% sure.

@aldomanetti When I select one OBJ as ‘OBJ File for 3D Plugins Sequence’ as you do at 0:30, I am able to load the entire sequence of OBJ’s into After Effects as one footage asset containing the entire sequence.

Are you able to open the same OBJs in other software like Blender? If not, have you opened them in a text editor to see if they have this issue?

I can open the OBJ sequence in Cinema4D and there is no problem. Also when viewing the OBJ with a text editor, it seems fine. (attached image).

Is it possible for you to send me an OBJ sequence that has worked for you for testing?

@aldomanetti I was able to load the Depthkit Cinema / Textured Geometry Sequence OBJ’s available on the Downloads page of the Depthkit website, as well as with other sequences exported from the most recent version of Depthkit.

Thanks for sharing. I tried it and it doesn’t work for me. So it must be my system. Maybe a clean install of AE will fix it.

@aldomanetti I did notice that in your screen recording, there’s an import option for Trapcode, so I agree that a clean install is a good next step.

I think I have already resolved the issue. The problem was thinking that natively AfterEffects could import OBJ Sequences, but it is not yet capable, it can only OBJ separately. And when using plugins such as Plexus, Element 3D or Trapcode, they enable the possibility of importing sequences but to be used with those plugins and not with the new 3D rendering engine that After Effects incorporates.
I’m looking for the look that I achieved with this capture that I share, but of course they are independent OBJs within AE.