[RESOLVED] Videos disappear depending on Unity editor cam position

Hey y’all,
I loaded a series of videos into a Unity scene, but they disappear when the camera is pointed directly at them. They remain visible only when they are not center frame of the editor window, but when they just vanish. I think the videos are culled when they are in the path of the camera frustum, yet I can’t say that for certain. Any ideas on what could be causing this? (Screengrabs below)




1 Like

Hi @SteveHorwath

This is an issue with Depthkit Core’s Mesh Bounds not being positioned correctly in relationship to the clip’s actual rendering geometry, which then causes it to get frustum-culled inappropriately and disappear. You can see the Mesh Bounds position when you enable Gizmos and observe the green bounding box associated with the clips’ Collider component.

You can work around this by moving the origin to the subject in relationship to the bounds. This can be accomplished this two ways:

  • In the metadata, change the boundsCenter.z value to the distance in meters that you want the origin be offset. The Depthkit example Autumn clip should have a value of 2.18890738487244 by default.

  • Parent the Depthkit object to an empty object, and use the Transform component of the Depthkit object to dial in the offset. Then apply any position/rotation changes to the parent.

We anticipate to address this issue in future releases of Depthkit Core. Hope this workaround helps for the time being!

1 Like

Hi James,
I’ll give this a shot and see it helps. Thank you for your quick response! Glad to hear you guys are on top of this.

1 Like

Hi I’m encountering this issue in the Unity Editor and neither cahnging the metadata offset or parent change solutions worked.
Im using a 3d pipeline and configured following setup in this forum( Depthkit for the Oculus Quest ).

Its always caused by a random movement of the editor/game scene in any direction causes the clip/poster to disappear.

Ok rather than changing the The boundsCenter in metadata, I increased the boundsSize.x and boundsSize.y to a higher value.

1 Like

@ConnorMarkus Did editing the bounds in the metadata fully solve the issue? Let us know if there’s anything else.

I found this solved my problem too. Worth noting that when I made changes to the metadata file Unity did not automatically update them. I had to drag the metadata file from the Project Window onto the slot in the editor to apply the changes. Once this happened you could see the green bounding box take up it’s new position in the editor.


Bumping this as I am currently working on solving this same issue, I have modified the metadata file to move the bounding box collider around the vfx and have tried modifying the size of the collider to more closely frame the vfx, but still having this issue. Feel like I’m just missing something obvious here, any help appreciated! Including screenshots of different collider positions/sizes I have tried

@WhittSellers Thanks for sharing these screenshots. The collider in the third image looks appropriate for your recording, but I am unclear on the nature of your particular issue - Does the Game Camera see the asset, then it disappears once you move the camera into a certain area, or is the asset not appearing at all? Can you make a screen recording showing the behavior of the error you are seeing while narrating a description of what you are changing? If you are able, please also share the video, poster, and metadata of the asset so that we can try to reproduce it ourselves.

You’re welcome and thank you for helping! The depthkit clip disappears both in editor and runtime depending on the viewport camera’s position and rotation. When getting too close to the front of the clip or too far away from the back of the clip it will disappear, and it will appear when looking at it indirectly but disappear when looking directly at it, like the camera is raycasting and if it hits the front (back?) plane of the effect bounding box then it deactivates. Here is a youtube link Depthkit Clip Disappearing - YouTube

Found the fix, I had to change the bounds in the VFX graph itself! When creating a new “Depthkit VFX Look” graph asset, it sets the bounds in the “Capacity” block at the top of “Initialize Particle” to a default of pos (0, 0.1, 0) scale (2, .1, 2). After adjusting those values manually to roughly the position and volume of the depthkit clip everything appears to be working correctly. I guess this means needing one vfx graph asset per clip unless the DK clips take about the same volume and are the same distance away from the camera?


@WhittSellers Nice work! I didn’t realize VFX Graph had it’s own bounds. I’ll update our troubleshooting documentation accordingly.

1 Like