Incorrect dependencies when building with Studio Lite

Hi there!
I’m testing the Studio Lite plugin in Unity and stumbled upon the issue showed in the picture.
I started in Unity 2021 and did another build on 2020.3 as it’s the one recommended to see if that was the issue.
Are these errors caused by a missmatch between the Core plugin and Studio Lite? AmI doing something wrong? I don’t have this problem with the normal Studio plugin.

@AlexEpa Con you confirm that you are importing the Depthkit Core package first, and then the Depthkit Studio Lite package? Importing them out of sequence could result in the error you are seeing, so I want to rule that out. Let me know if the issue still persists.

Hi Cory,

I can confirm that the Core package was imported first. I used the Studio Lite package in the same project as the normal Studio.
No error appeared during the installation of the packages, only during the build process.

I can also add that I already did several normal Studio builds for HoloLens 2 with no issues during the build process, only with Studio Lite this problem appears.

@AlexEpa Thanks for confirming. We are looking into this, and will send you updates when we have them.

Out of curiosity, what were your results when running the build with Depthkit Studio on the HoloLens 2?

Crash after 10 seconds. :smiley:
I tried to extract logs to see what is the cause, but no luck, and the emulator has no issues.
Mi initial thought is that there is a RAM spike at the stat of the program that make it crash.
I also tried with Holographic Remoting and it works.

1 Like

Hi @AlexEpa, update here - we’ve identified the build issue and will be sharing a pre-release patched Unity package for you to test over email early next week. Thanks for your patience and diligence in reporting the issue to us!

I’ll be looking forward to test it as soon as I receive it, thanks.

@AlexEpa I just sent you an email with the pre-release patch of the Depthkit Expansion packages for Unity. Let us know if this resolves your issue - Thanks!

@AlexEpa Checking in to see if the patch that I sent via email addressed the issue you were experiencing when building to HoloLens with a Depthkit asset. If so, let us know so we can close the ticket. If not, let us know what is still occurring so that we can continue to troubleshoot.