[RESOLVED] Error when building AR app


I am trying to create an app using an AR project in Unity. I followed your tutorial to import package and files in the AR project, but when I try to build the app, I get the following errors:

Shader error in ‘Depthkit/Core/Depthkit Core Photo Look Built-in RP’: redefinition of ‘inRange_ii’

Would you be able to help me solve this issue?

Thank you!

Hi, @NAL - To help troubleshoot, can you provide the following:

  • Which Unity version you’re working in
  • Which render pipeline the project is using (Built-in, Universal RP, HDRP?)
  • Which physical device you are testing
  • Which operating system version is installed on that device
  • Can you also share screenshots of how your Depthkit object is configured in the Inspector?

I’ll keep an eye out for your responses and go from there.

Hi @CoryAllen,

Here is the information:

  • Which Unity version you’re working in - 2022.3.9f1
  • Which render pipeline the project is using (Built-in, Universal RP, HDRP?) - Built-in Render Pipeline
  • Which physical device you are testing - Samsung Galaxy A53
  • Which operating system version is installed on that device - Android 13


Thank you!

@NAL - The Samsung Galaxy A53 is one of many devices with a Mali GPU, which doesn’t support Depthkit’s compute shaders - See discussions here and here. Do you have an Adreno-based device to test on?

Also, be aware that the current version Depthkit Expansion Packages for Unity (Phase 9) is only tested with Unity 2020.3, so using it in newer versions like 2022 may produce unexpected results.

Hi @CoryAllen,

Thank you. I tried with an Adreno-based device and it worked well, with Unity 2022.

I know it might be hard to estimate, but do you have a rough estimate of when Mali-based devices will be supported (weeks, months or years)?

Thank you.

@NAL - Currently, the way to get Depthkit captures to playback with wide device/platform support is via third-party integrations like Arcturus HoloEdit (which has specifically only been tested with full-body Depthkit Studio captures, not single-sensor captures).

We have added a streaming mesh format to our roadmap, which may solve this compatibility issue with devices like the Mali-based devices you are testing, but I do not have timeline to share yet.

Hi @CoryAllen ,

Thank you. Do you have a channel to reach out to Arcturus Studio ? I tried to contact them several times via their website, without any response from them.

Thank you.

@NAL Can you confirm that you’re attempting to render a single-sensor Depthkit Core capture on your mobile device? Based on your use of the Depthkit Core components in Unity and the thumbnail if your combined per pixel video visible in the screenshots, I assume this is the case.

As I mentioned above, Arcturus is only intended for full-body, multi-sensor captures made with Depthkit Studio, but if this is what you’re trying to render, we can connect you to the Arcturus team.

If you are indeed rendering single-sensor Depthkit Core captures, another approach which may interest you is the Depthkit.js web renderer. This open-source repository is now community-maintained, and no longer falls under direct Depthkit support, but may be a suitable option for you.

Thank you @CoryAllen, yes I’m making single-sensor captures. I will have a look at the Depthkit.js web renderer.

1 Like

@NAL Circling back to this thread now that Depthkit version 0.8.1 has been released, supporting the new Draco-encoded streaming geometry export format for playback using the new Depthkit.js, and optionally 8th Wall.

Have you been able to successfully get your Depthkit captures to play using the new 8th Wall template? Let us know if there are any outstanding issues - Otherwise, we will close the thread.

Hi Cory,

Yes I was able to successfully play Depthkit captures using the new 8th wall template. Thank you!

@NAL Glad to hear it!