Low quality export from Unity

Hello !

We’re currently working on a project where we would only need 1 frame of our capture to later design our subject in Procreate, but we noticed that the exported files from Unity (using the studio mesh exporter) are only 2 mega bite each , which makes our 3d object very pixilated later on in the process. Is there a way to get a better quality ?

@PatriceLaCroix Hi, can you share screenshots of

  • your asset as it appears pre-export in Unity
  • The reconstruction settings, particularly volume density, in the Depthkit Studio Mesh Source Component?
  • The exported mesh in another 3D tool like Meshlab

Here it is!

@PatriceLaCroix Thanks for sharing. I see a couple things you can adjust:

  • Volume Density is set to 102.1 - For the Mesh Export Workflow, we recommend a density of 175-200, which will reduce the size of each voxel (and also increase the file size of each mesh). Be sure to set the surface buffer capacity after adjusting.
  • Surface Smoothing is disabled. We recommend enabling it, and adding a small amount (~0.3 - 0.5) to smooth out some of the depth noise and get rid of tiny geometry islands, but not so much that if flattens details like noses and fingers.
  • It’s tough to tell from the Unity screenshot, but you may be able to get back some details like fingertips by making small adjustments to the Surface Sensitivity and Weight Unknown/Unseen tools, especially after having applied Surface Smoothing.
  • When making these adjustments in Unity, change the Scene View Mode (in the top left of the Scene panel) from shaded to Wireframe or Shaded Wireframe to preview the size of the faces/triangles of the exported mesh as you adjust.

Oh interesting , we didn’t even know that these settings were affecting the export!
I followed your recommendations, and now our mesh is at 10mb, which is better but still very low quality…?