Studio Mesh Sequence Exporter Issues

We are using 5 Kinects including 1 Black Magic camera.
I have been having issues with the export. I followed this guide step by step.

  • First we had the issue regarding the Render Texture resolution. The original image resolution out of Depthkit was 16560 x 6912 pixels which is too big for Unity I think?
    I then downsized the images to 5520 x 2304, which worked.

  • Everything is in place and playback was possible. I put the mesh export component in place, pressed play and pressed on the Start Export button.
    I could see how the timeline would go from start to end after which I got the “Capturing Finished” message in the console.
    However when I checked the export output map it is still empty. Attached is my console log.

1 Like

@GlennWustlich sorry for the delay here.
I can’t immediately identify the issue based on what you shared. However, I’m missing a few things that could help. Could you post a full screen recording of you setting this up and hitting export? That will really help in spotting where things may be misconfigured or software bugs breaking the workflow.

It would also be helpful for you to include a detailed screenshot of how the Mesh Sequence Exporter is configured in the Editor.

We’ll share this with the engineering team this morning in case they see something immediately that i’m missing.

Thank you for sharing it with the engineering team. Hereby the screen recording, with me scrolling through the configuration as well:

1 Like

Hi @GlennWustlich

From the log, it looks like the mesh is not being downloaded correctly which will prevent the system from outputting anything.

It looks like you’re using a scriptable render pipeline, as evidenced by the Depthkit Studio Shader Graph Look component. This workflow currently only supports the Built-in Render Pipeline. Please try using the built in render pipeline and let us know if that fixes the issue.

You may need to rebuild your game object to ensure it is set up correctly for the built in pipeline.

Tim, you are the best! It is working now. :slight_smile:
Would be great if this could be put in the documentation (or if it can be made to work with URP also)!

1 Like

@GlennWustlich I’ve added a callout to the documentation regarding this. Great suggestion!

1 Like