[RESOLVED] Azures Kinects not connecting

Hey there

Ive been struggling with getting my Kinects connected to a new computer that I put together. Im not able to call the sensors up through CMD nor the viewer. The cameras are working on my older PC and they are all up to date etc, they load up just fine on the machine. I want to use 5 sensors.

Any advice would be highly appreciated. Thanks!!

Windows 10
12th Gen i9-12900KF
Mag z690 Tomahawk (MS-7D32)
Renesas USB 4 port Startech
NVIDIA GeForce RTX 3080 Ti
Cable Matter Extenders (current not in use, using the original USB’s)

Theses are the errors that I get:

[ error ] : find_libusb_device(). Unable to open LIBUSB at index 0
[ error ] : usb_cmd_create(USB_DEVICE_DEPTH_PROCESSOR, device_index, NULL, &depthmcu->usb_cmd) returned failure in depthmcu_create()
[ error ] : depthmcu_create(index, &device->depthmcu) returned failure in k4a_device_open()

C:\Program Files\Azure Kinect SDK v1.4.1\tools>AzureKinectFirmwareTool.exe -l
== Azure Kinect DK Firmware Tool ==
[2022-09-29 21:49:00.626] [error] [t=3988] D:\a\1\s\extern\Azure-Kinect-Sensor-SDK\src\usbcommand\usbcommand.c (370): find_libusb_device(). Unable to open LIBUSB at index 0
[2022-09-29 21:49:00.628] [error] [t=3988] D:\a\1\s\extern\Azure-Kinect-Sensor-SDK\src\color_mcu\color_mcu.c (74): usb_cmd_create(USB_DEVICE_COLOR_IMU_PROCESSOR, device_index, NULL, &colormcu->usb_cmd) returned failure in colormcu_create_by_index()
Found 1 connected devices:
1: Device “…”

I tried these two approaches mentioned by Cory in a different post too and still no luck yet.

  • Sometimes other applications, like a web browser, will take exclusive control of the sensor to use as a webcam, so make sure all other applications are closed. Windows will even sometimes use the Kinect’s microphone array as the system’s default audio device, but you can disable the microphone array in Windows Sound Settings to ensure there aren’t any conflicts.
  • You can also reset the Azure Kinect drivers in Windows by removing the sensor, showing hidden devices in Device Manager, and uninstalling the grayed-out Azure Kinect, then plugging it back in.

@Telmo, sorry to hear you’re having trouble with your sensors.

First, can you confirm that all the sensors are properly powered with their own power supply, and show a solid white LED on the rear of the sensor?

Next, I recommend unplugging the USB cables for all sensors, then plugging them in one at a time, and after plugging each one in, open each connected device in Azure Kinect Viewer and start streaming for a couple of seconds to confirm which sensors are working and which ones aren’t. Once you have confirmed a good connection to each of the connected sensors, then plug in the next sensor, refresh the devices, and repeat.

Do you have one or two StarTech USB PCIe cards? If you only have one, and are attempting to use 5 sensors, try different ports on the motherboard for the 5th sensor. Are you able to connect 4 sensors using only the USB PCIe card? Have you identified which chipset the sensor connected to the motherboard port is using?

Hey Cory

Yes, all sensors are powered with the original cables. I have the ‘cable matters’ extenders but not currently using them yet.

Im able to get 3 of the 5 Kinects to connect. They are all on the same firmware version and work on other computers.

For some reason I am unable to list or query any Kinects via the command prop, however I can do so on my other “older” PC.

Also, Im not able to connect any data through the StarTech card. therefor I have been using it to power the sensor and then connect the data to the onboard USB3 ports. *Should I rather power the sensors externally and not on the PC?

I have one StarTech 4 port usb3 card. I have tried all kinds of combinations of different ports, cables and cameras.

As far as I have have identified, there are 5 working USB3 ports on the motherboard. I have tested each one individually so assuming the chipset is not the issue.

Any advice will be welcome.

Thanks Cory

@Telmo, are you able to detect, open, and stream from each sensor when there is only one sensor plugged in at a time? What color are the LED’s on the front and back of each Kinect when they are all plugged in and you are trying to stream?

If, when plugged in to the PC one at a time, the sensor fails to stream or be detected, follow Microsoft’s troubleshooting steps. In particular, uninstalling the Kinect in Device Manager (it may be hidden), then disconnecting it and reconnecting it may help.

If they all successfully stream individually, but some fail to stream when they are all plugged in, try the following:

  • Check the state of the LED’s on the front and back of each sensor - They should both be solid white. If they aren’t, then there’s likely a power or data connection issue - See Microsoft’s documentation.
  • The computer’s USB ports may not provide enough current to power the sensor, so power each sensor externally with the included AC power supply.
  • Although the motherboard USB ports work with the Azure Kinect, they might not have the data bandwidth for multiple sensors if multiple ports share the same USB controller. The StarTech PCIe card solves this by providing one USB controller per port, so use the StarTech PCIe card for the data connections to the sensors.

Hi Cory

Im still getting inconsistent errors with my system. It may be the StarTech card thats being buggy. Im getting the PC looked at and Ill revert back asap. Thanks for your help so far.

@Telmo Please let us know specifically what you are seeing with regard to the sensor LED indicators, as well as any other information you are seeing on the screen which may be helpful in diagnosing this.

@Telmo Are you still experiencing issues with sensor connectivity? If so, let us know what specifically you are seeing - Otherwise, we will close this ticket.

To close the loop on this, the troubleshooting steps to fix this issue can be found in the Sensor connection issues section of our documentation under the subsection ‘Azure Kinect “Failed to open device”’.