[RESOLVED] Startech PEXUSB3S44V USB card not working

Hi there.
I’m trying to get my Startech PCI USB card to work with my Azure Kinects with no luck.

Following the instructions in the Depthkit Studio hardware requirements page I’ve uninstalled the Renesas USB devices, then rebooted Windows so it automatically installs the compatible Microsoft drivers but it isn’t working.

The driver version that it’s currently installed is the 10.0.22621.1635 (4/14/2023), in the requirements page there’s a picture that shows the 10.0.19041.1081 version, but the picture doesn’t say if that’s the compatible one or not.

Any help? Thanks!

Hi, @FedericoGuardabrazo - Sorry to hear you’re having issues with the sensor connection.

The screenshot in our documentation was the most recent version at the time the guide was published, and we haven’t run into any issues with the drivers Microsoft has released since then. I will clarify this in the documentation.

Can you provide some more information about the computer you are using and the troubleshooting steps you have already tried?

  • What is the behavior you are seeing that indicates there is an issue? Are the sensors not appearing in Depthkit? Are they not appearing in Windows Device Manager? Are they listed but fail to stream?
  • Which version of Windows are you running? (As reported in “About Windows”, e.g. “Windows 10 Version 21H2 Build 19044.2965”)
  • Do other USB devices work when plugged into the StarTech card’s USB ports?
  • Are the sensors successfully streaming in Depthkit (and/or the Azure Kinect Viewer utility found in the Azure Kinect SDK) when plugged into other USB ports on the computer, but failing to do so when they are plugged into the USB ports found on the StarTech card?
  • What is the status of the indicator lights on the front and back of each sensor when it is plugged into the StarTech card?
  • Are you plugging the sensors directly into the StarTech card’s USB ports using the 3’ USB Type-C to Type-A cable provided with the sensor, or are you using extenders or alternate cables? If using other cables, have you tried bypassing them to see if they are introducing any issues?

Let us know the answers to the above, and we’ll go from there. Thanks!

Hi there. I won’t be able to check some specs till tomorrow but I’ll do my best:

  • The sensors appear in DepthKit and they start working but after a few seconds they stop working and the log says that they are dropping frames.
  • I’m using Windows 11 (I’ll be able to give you the specific version tomorrow). I’ve also tried a different computer with Windows 10 with the same results. Both are using ASUS motherboards (Z690-P Wifi and PRIME X470)
  • Other devices work just fine in the StarTech card (external SSD, mouse, keyboard…)
  • The Kinects work just fine in DepthKit and Kinect Viewer Utility when plugged to other USB ports on the computer, so I don’t think it’s a cable issue.
  • The indicator light is solid white when plugged into the StarTech card.

Thanks in advance! I’ll provide the specific Windows version ASAP.

@FedericoGuardabrazo Thanks for the clarification. In addition to the Windows version, can you also provide the following:

  • How many sensors are plugged into the StarTech card, and how many sensors are plugged in to the computer in total? Does the problem still exist when fewer sensors are connected?
  • Which color resolution and depth resolution is each sensor set to when you start streaming? Does the problem still exist when the sensors are set to a lower color resolution?
  • Which model of CPU and GPU does each computer have?
  • It sounds like you are seeing this issue as soon as the sensors start streaming, but have you attempted to have Depthkit record the streams to see what behavior the Recording Diagnostic Panel shows while Depthkit is recording? The dropped frames reported in the Diagnostic Panel are a more accurate metric than the messages appearing in the console, so if you can describe (or better yet film with a phone) the behavior of that diagnostic panel, that may provide more insight into the issue.

Hi there!

We’ve rebooted everything, updated the Kinects’ firmwares and that seems to have pleased the USB gods. Everything’s working now.


1 Like

@FedericoGuardabrazo Glad to hear it’s working, benevolent deities or otherwise!