[RESOLVED] OSC API - Commands not working


Trying to set up TouchOSC with the new update. Some commands like /startCapturePipeline work fine, but /setExtrinsicSamplingState 0 , /setExtrinsicSamplingState 1 , /setFloorSamplingState 0 and /setFloorSamplingState 1 dont seem to elicit any response.

Any ideas?

Hi Oliver,

Glad to see you are diving into the new Remote Control API. Your system for using remote desktop to calibrate was a big inspiration for us to implement this feature.

One thing that could help are to use our prebuilt Touch OSC templates:

If those templates still don’t work, a few other tips:

Verify the IP, Port and network domains

  • Be sure you have enabled OSC in the Depthkit Edit > Preferences panel
  • Ensure the IP address and port match between Depthkit and Touch OSC
  • Ensure the Phone is connected to the same wifi as the PC, and that you are using the IP associated with the Wifi in case the PC is also hard-wired to the network

If that’s all verified and it still doesn’t work, it may be a network issue:

  • Can you confirm that TouchOSC can send messages to other OSC receivers on that computer (use TouchDesigner or other as a test receiver)
  • Can you test to see if Depthkit can receive messages from a local sender?
  • You can also try disabling windows fire wall (see below) in case the network is blocking the request. see below screenshot:

Let us know if any of this troubleshooting helps!

Thanks James - awesome!



1 Like

Hello James,

Sadly i have as well problems with the Osc remote function.

I use the prefabs and think I followed all advices and rules but still depthKit doesn’t start when I start OSC touch (as editor) push play button for the downloaded prefab and sadly nothing happens. As well I downloaded the software at the PC (windows) and I load the prefab and start the play Modus and nothing happens inside of depthKit ?

What maybe could be the reason I am only hardwire connected to the network and the iPhone via WiFi … could this be an issue ?

Greetings Martn

@MartnD Have you checked each of the bulleted items in the Troubleshooting section of our Remote Control documentation? I suspect that it’s likely one of these, particularly a mismatched IP address or port number, and if those match, perhaps the firewall issue also mentioned in the documentation.

Was the Windows PC that you downloaded and ran TouchOSC on the same PC which was running Depthkit? If so, were the IP settings set to Were you able to receive OSC messages from that app in any other software like TouchDesigner (making sure that Depthkit and the other app are not using the same port at the same time)? If this local messaging on the same computer works, but messaging over LAN/Wi-Fi doesn’t, it’s likely a network, firewall, or IP configuration issue.

Please let me know specifically which troubleshooting steps you have tried, and I will be able to guide you to further troubleshoot.


Thx I check localhost … and it worked … then I double check the mobile phone setting and :frowning: it was a 5 in the end instead of an 4 :slight_smile:

so now calibrating works and starting stream for potential record

but the record button is not working

I guess it is an error in the prefab script which i downloaded?

@MartnD Good catch! The template file was misconfigured. I have uploaded a fixed version to our Remote Control documentation. Thanks for letting us know!