[RESOLVED] Problems with new version of Oculus Quest 2

we are working currently on our experience. it integrates modeled 3d environments along with a volumetric image of our protagonist shot by depthkit cinema.

i’m addressing you since we encountered a new problem in the last few days

the experience is built on unity 2022.3.22

there has been an update of the quest 2 in the last few days.
It turns out that a quest that was updated to version 53 has a problem to run the volumetric image – the image appears as a damaged and broken one. On versions 51 or previous the quest runs it perfectly okay

attached please find two screen shots of the same scene –

one with the full volumetric image captured on an older version of the quest 2 (version 51)

the other with the broken image captured on version 53

do you experience this problem?

do you have any solution for it?

Currently, since we are still in the development stage, we use a free version of the AV PRO. Is the problem relate to it in any sense?

Thank you in advance

above is the screen shot of the same environment with the full image

Hi, @user2.

The Depthkit Expansion Packages for Unity are only tested in Unity 2020.3 (LTS), so we can’t guarantee support in the Unity version you are using.

We also haven’t tested using the new Oculus SDK version, but if the previous version (51) was working, our recommendation is to revert back to that until the issue is identified.

It is relatively easy to test to see if AVPro is introducing issues. First, be sure that you’re using the latest AVPro version. If that doesn’t change anything, simply switch the Player type in the Depthkit Clip component to Unity Video Player, and reconnect the media files. If that works, then AVPro interacting with the new Oculus SDK may be the issue.

Hi Cory

I’m not familiar with a way to revert the Quest to an older version. Can you assist me with this?

thank you


Hi @user2 -

There is a guide here on how to switch to a different version of a Unity package: Unity - Manual: Switching to another package version

Hi Cory

I asked for your assistance in reverting the version of Quest 2 from 53 to 51 or older. The above link is related to the installation of packaging in Unity only. Do you know of any relevant explanation for changing the version in Quest?

thank you

Hi cory

It has been nearly two weeks since I first contacted you about the problem with the Quest, and so far, you haven’t suggested any viable solutions.
Is there a technical solution available for this situation?

thank you

hi @user2

Thank you for following up, I understand your frustration as it appears the new version of Quest OS has broke Depthkit captures in your build. It’s hard for all of us developers to keep up with the ever evolving ecosystem of dependencies in both Unity, the hardware and the hardware operating systems.

Please keep in mind that as you are using Unity 2022.3, we cannot guarantee support for Depthkit playback. We currently test and verify our Unity plugin against 2020.3 LTS. In Cory’s initial response he noted that you are using an unsupported Unity version. Have you attempted to revert the project to our supported Unity version?

Regarding rolling back Quest’s operating system or other developer components, this is something that you need to get support for directly from Meta. We cannot offer support for Meta’s products or Unity’s products directly. A good place to start is their support portal here: https://oculusdevelopers.zendesk.com/hc/en-us

I recommend the following test to diagnose where the issue lies so that we can better guide your debugging next steps:

Build a simple clean test project in Unity 2020.3 that contains just the Depthkit capture onto your Quest with its current OS version. If the capture appears, then we know it’s either an issue with Unity, or some other interaction in the full scene you have built out.
If it does not appear, then we know it’s an issue with the OS upgrade that broke our plugin!

Let us know how it goes with this test and we can take it from there.

Hi @user2

I am unable to recreate your issue with playback, and am seeing Depthkit Core clips playing back without the issues you report

Can you provide more details to reproduce the issue?

Here’s what I did to attempt to reproduce the problem

  • Updated Oculus Quest 2 to the latest OS (version 54 as of today)
  • Created a URP project in Unity 2020.3.48f1
  • Added depthkit.core and depthkit.core.shadergraph packages from Phase 8 (Depthkit_Studio_Expansion_Package_Phase8_030722.zip)
  • Imported a Depthkit Core clip captured from Depthkit
  • Setup a Depthkit Clip and Depthkit Shader Graph Look
  • Added XR Plugin and configured for Oculus XR, Android build target, Converted the main camera to XR camera rig
  • Built to Quest 2 and the clip displays normally
  • I then did the same with AVPro (2.1) player and depthkit.avpro and it also worked normally.

A few things to check on your end:

  • Ensure you are running URP pipeline and Depthkit Core Shader Graph Look for the Look Component
  • Ensure your surface buffer capacity has sufficient memory (mine needed to be at 41%). Do this by clicking the Set Surface Buffer Capacity in the Editor when the thumbnail is showing.
  • Can you run ffprobe on your video and provide the results? There is a chance the video is encoded in a way that is disrupting the playback. The video I encoded returns the following:
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'TAKE_06_12_20_55_14_Export_06_12_20_56_52.mp4':
    major_brand     : mp42
    minor_version   : 0
    compatible_brands: mp41isom
    creation_time   : 2023-06-13T00:56:53.000000Z
  Duration: 00:00:03.60, start: 0.000000, bitrate: 24503 kb/s
  Stream #0:0(und): Video: hevc (Main) (hvc1 / 0x31637668), yuv420p(tv, bt709), 736x1168 [SAR 1:1 DAR 46:73], 24500 kb/s, 30 fps, 30 tbr, 30k tbn, 30 tbc (default)
      creation_time   : 2023-06-13T00:56:53.000000Z
      handler_name    : VideoHandler
      vendor_id       : [0][0][0][0]
      encoder         : HEVC Coding

See my settings window for reference:

hi James and Cory. following is our reply
ok, switching from Depthkit Studio Shader Graph Look to Depthkit Core Shader Graph Look has made the clip run regular again.
It’s quite strange as we used the Studio version up until now, in URP, and it worked great.
But, with the Core version there’s a different issue that appears in Scene Mode \ Play Mode and Build - you can’t view the volumetric video gameobject if you’re close to it a few meters - only from afar.
Strangely, its visible if you turn the gameobject 180 degrees and view it from behind (which is not what we want, obviously).
We have the same project settings as you do.
This occurs in our main project and the new test “clean” project (unity 2020).

This issue did not appear in the STUDIO version of depthkit that we used up until the new Oculus versions were released.
I suggest you might also check if your STUDIO versions work for the VR standalone quest with V54. (for us, they cause a break in the footage, like we sent you before)

looking forward for your advice

For clips disappearing based on the camera position, check out this thread

@user2 Per the email from your team, I am marking this thread as resolved. Let us know if there’s anything else we need to address. Thanks!

hi Cory
we’ve just encountered new technical problem. Tal posted the following in a different thread


I’m working on a Unity project that has depthkit volumetric video clips in it.
I downloaded your latest Phase9 exapnsion pack, followed all instructions.
I’m using Unity’s video player (not AVPro).
I’m using the Universal Render Pipeline.

In Editor - the clip is shown great, with audio, as expected.
Once I export the Android project to the Quest 2 (V56 is installed on the device, the latest oculus version) - I can’t see the volumetric video, only hear the video’s audio.
I tried with both the Core and the Studio implementations - same result in both. :frowning:
I opened a clean new project and tested it there - still doesn’t work…

My Android settings are:
API Level 32
.NET Framework

Would love your help in understanding what I’m missing!
Maybe you could try to reproduce this on your end, please? Just to see that I’m not crazy?
Thank you so much!

Hi, @user2 . I will address this most recent issue in the other thread.