[RESOLVED] Dephtkit Unity renderer not working on Quest firmware v56 (no visuals in build)


I’m working on a Unity project that has depthkit volumetric video clips in it.
I downloaded your latest Phase9 exapnsion pack, followed all instructions.
I’m using Unity’s video player (not AVPro).
I’m using the Universal Render Pipeline.

In Editor - the clip is shown great, with audio, as expected.
Once I export the Android project to the Quest 2 (V56 is installed on the device, the latest oculus version) - I can’t see the volumetric video, only hear the video’s audio.
I tried with both the Core and the Studio implementations - same result in both. :frowning:
I opened a clean new project and tested it there - still doesn’t work…

My Android settings are:
API Level 32
.NET Framework

Would love your help in understanding what I’m missing!
Maybe you could try to reproduce this on your end, please? Just to see that I’m not crazy?
Thank you so much!

hi cory, so you will reply here? :slight_smile:
looking forward to see if you managed to replicate the issue with both core & studio with the new quest v56…!

Hi, @Tal_MichaelHaring - Thanks for sharing all of the details of your build. It looks like all of your build settings are correct.

The most recent test we have done on Quest was with firmware v54.0 - It can be challenging to keep up with Meta’s release schedule, as they update their firmware far more often than we update our packages. I’ll slate some time Thursday to update our headset and test it with the new version, and keep you posted as I have updates.

To confirm, you’re still attempting to render a Depthkit Core (single-sensor) asset, correct?

yes, that’s correct!
and thank you so much Cory, i appreciate your help!

@Tal_MichaelHaring Some updates from our initial testing:

It looks like the Depthkit Expansion packages for Unity are still compatible with the current production firmware (v55) for the Meta Quest.

When updating our Quest Pro to the public testing firmware (v56), we did encounter some issues, but they are different from the invisible asset you describe. Since we don’t explicitly support pre-release versions of the Quest firmware, and this issue may be resolved by the time Meta puts this version into production, for now we are investigating further, and will let you know when we have updates.

Hi Cory!

Thanks for checking it!
Just to make sure - we’re using the Quest 2, which has different specs than the Quest Pro, and is obviously more commercial and standard.
I still can’t see the volumetric video, even after many changes and testing to the parameters and settings in Unity…
I did however managed to see the volumetric video when switching to Vulkan - but the video is playing completely stuttering, as if rendering a frame every few seconds…
More settings changes to Unity and Vulkan didn’t help… obviously can’t test AVPro with Vulkan…
If you have any thoughts on this, that’d be great.
I don’t want to use Vulkan however, as it drops my FPS significantly, as opposed to OPENGLES3…

Thank you again!


just to add - we would be happy if you could stay on this issue for us, as we cannot view the volumetric in build on the quest 2, which is our target device, and so we cannot release the project because of it… :confused:

@Tal_MichaelHaring We have investigated further and are still identifying the cause of the issues we are seeing when running v56 on the Quest platform (both Quest Pro and Quest 2). We’ll keep you posted once we have more information.

@Tal_MichaelHaring I just sent an email to your team with a patched version of our Unity packages which may address this issue. Please test it and let us know your results.

first initial test - it works!!
let me do a deeper dive test of all our clips and scenes, all will let you know finally - but thank you so much cory for all your help so far!!

1 Like

after continuois testing - your new 9.1 version works great!!
thank you so much cory!

@Tal_MichaelHaring Great to hear!

For anyone else, we are performing some additional internal testing, and will have this patch available to download from our website soon.