[RESOLVED] Video/3D Model invisible

Hi James,

I have a question regarding cutting together Depthkit recordings. We had already written by mail regarding this:

"Another question (does this work?): Is it possible to edit the mp4-files with multiple cuts to add different cello-recordings together? We are thinking about fast cuts where the cellist sits and stands and turns around etc.

→ You can definitely add multiple cuts together into a single MP4 file, assuming that you do not change the volume boundaries so that the metadata is the same for each sequence that is spliced together."

The problem now: When I load the PlugIn with the edited video and test the project on the smartphone, I notice that only the sound of the video is played, but the video itself is invisible.

Do you have any idea what could be the reason for this?

Kind regards,

Felix

@FelixKnoblauch There are a number of reasons that the edited clip is not rendering on the device (e.g. the exported edited video has different values in some of its metadata tags than the original video). Is it possible to share both the original video and metadata, as well as the edited version so that we can take a look and compare them?

Sure, here you will find the files I used.

https://drive.google.com/drive/folders/12PzjV2-tI_YqLVeoQMLcViaYXL_pOdvg?usp=sharing

Thanks for checking!

@FelixKnoblauch - I took a look at both videos in ffprobe to compare, and spotted these differences (working “Depthkit” version above, not-working “Resolve” version below):

  • The Depthkit version has the H.264 Main profile applied; The Resolve version has the H.264 High profile applied at encode/export. The High profile might not be supported by your player or playback device.
  • The Depthkit version has PC (aka Full-Range) color applied; The Resolve version has TV (aka Limited) color applied. We recommend adhering H.264 videos to PC color, and even injecting additional colorspace metadata to ensure that the hue-encoded depth is interpreted properly, avoiding distortion in the geometry at render time.
  • The Depthkit version has a resolution of 4092x4096; The Resolve version has a resolution of 3840x2160. You can either re-export at a matching resolution, or change the Resolve version’s metadata to match the new resolution.
  • The Resolve version, in addition to the video and audio streams, contains a 3rd stream for metadata (e.g. timecode) which may not be supported by your player. It may be possible to re-export out of Resolve without this stream added. If not, you can try muxing just the video and audio streams into a new container without the metadata stream.

@FelixKnoblauch - Per your DM, I am adding some additional information here:

Different playback devices (e.g. Windows computers vs. mobile devices) and players (e.g. Unity Video Player vs. AVPro) have different requirements, so there isn’t one set of encoding setting that’s ideal for all scenarios.

That said, I took a look at Resolve’s export options, and have highlighted the parameters which I believe match those of videos exported directly from Depthkit in this screenshot:

Format: MP4
Codec: H.264
Resolution: Custom (match the original video and the timeline you’re working in)
Framerate: 30
Encoding Profile: Main
Pixel Aspect Ratio: Square
Data Levels: Full
Color Space Tag: Rec.709
Gamma Tag: Rec.709

Please keep in mind this hasn’t been thoroughly tested, and may produce some distortion artifacts in the geometry, but hopefully a video exported with these settings will play back for you. Give it a try and let us know how it looks.

@FelixKnoblauch - following up on this. Were you able to get clips to export out of Resolve with these settings and display properly in Unity?

Hi Cory,

sorry for the late reply! We have managed to export the edited video from Davinci.

I uploaded it to GoogleDrive for testing (“edited file with original metadata”). [Depthkit - Google Drive ]

Unfortunately, it didn’t really solve the problem. You can see what we get now in the screenshot.

I think we are already a huge step further - now we can see something at all. But we’re not quite there yet I’m afraid.

Can you see where the current display is failing?

Best regards and thanks for your patience,

Felix

Hi, @FelixKnoblauch thanks for the update. We are sprinting to get the new version of Depthkit out, but we will take a look at this as soon as we get the chance.

1 Like

Hey, could already you figure out the problem with our video file? Thank you!

@FelixKnoblauch I took a quick look at your files, and both the original and edited versions appear to play back fine on my end (original left, edited right):

Can you share a screenshot of the inspector while your Depthkit object is selected so we can see the components and settings you are using? Based on your previous screenshot where the texture of the character is completely blacked out, I suspect you may have the incorrect look applied for your pipeline. Can you also confirm you’re using Unity’s Built-in Render Pipeline for this project?

@FelixKnoblauch - Following up to see if you were either able to get your edited video to appear, or if you have not and can instead share the settings of your Depthkit asset in the Unity inspector, and confirm which render pipeline is being used. Let us know if you have any updates.

@FelixKnoblauch As I haven’t heard any updates, I am marking this thread as resolved. Let me know if we need to reopen it.