Zero Days Look suddenly not showing in Unity builds AND video lags

Suddenly when I build my project, the Zero Days looks revert to Photo inside the headset (Oculus Go). When I play the project inside Unity, it shows my Depthkit clips with the customized Zero Days looks applied and it’s all good. I’ve tested this with the Unity video player and with AVPro Video - same results with both.

I did make some changes to my player settings but then reset them.

Also running into many issues with the videos lagging both image and audio.
Any suggestions are welcome!

Hey @ElizabethLeister!

Sorry you’re having trouble. I think what you’re experiencing is two issues.

First the ZD look not working. Were you ever able to see the Zero Days look inside the Oculus Go? We haven’t directly tested this and I think the Zero Days look may not actually work in the Go. If it was working though and now isn’t working, that may be a separate issue.

In regards to playback being slow, I think that’s likely an issue of using a combined per pixel video straight out Depthkit. Right now those videos have a bitrate of 10M, which is not mobile friendly. I recommend re-encoding your video with something like ffmpeg to make the bitrate be 1-3M. A sample command that would do this is:

ffmpeg -i mycppvideo.mp4 -b:v 1M out.mp4

Let me know here about any of this, happy to help!

Hi Kyle,

Thank you.

Zero Days had been working on the Go and then just stopped.
Wondering if I just need to test on a Rift? Do you think the Quest will be better than the GO?

I re-encoded with ffmpeg and it made a huge difference (thanks!) but there’s still some lag. I have five depth clip files

in one scene, approx. one-minute total. All five figures speak simultaneously so the sync between image and sound is important.

Any other suggestions - maybe something with the audio…?

Appreciate your help.

Eizabeth

Hmm, if it was working and then stopped working something else must have changed. Did you add a lot of stuff to your scene? More Depthkit clips? Update Unity? Just trying to figure out what would have caused it.

I also recommend looking into adb logcat, as that way you can print out a debug log to your connected computer to see what the issue may be.

Glad to know ffmpeg helped you! Playing back 5 clips on mobile is definitely going to have performance issues in general, so I’d just keep lowering their quality until they can’t go lower. Trying bitrates like 500K would likely be fine, especially if your clips have the ZD look on them. Also make sure your clip mesh density is low.

Let me know what you find from adb logcat and if lowering bitrates helps as well. Also let me know what has changed in your Unity scene as that seems likely to be the culprit.

Thanks again Kyle.

So, I had my meshes all set to High which was part of the problem. Also working with 500k bitrates and all is working much better.

I still don’t see Zero Days in the headset and continue to troubleshoot. I have not upgraded Unity (for fear of these very issues…) Even with five clips, it was working at one point. I think it started when I began working with AVPro Video…? But even working with the straight Depthkit clips - doesn’t show up in the Go…

Happy to know things are running smoother! I think one thing that may make the look go away, especially if you imported a new package like AVPro, is that you lost of Unity define that turns of the ZD look. Go to the scripting defines symbols of your player settings in Unity:

Make sure in this list of defines you still see DK_USING_ZERODAYSLOOK in the list. If you’re using AVPro you should also see DK_USING_AVPRO. Make sure these are also present in the the defines for each platform as well, which you can select using the tabs at the top of this editor window.

Kyle -

It’s all working! Depthkit is showing up in the Go

and sound and image are in sync.

Big thanks to all of your help with these issues.

Elizabeth

1 Like

Glad you got it working!