Can't playback clip via animation track in Unity

I have followed the instructions to a T, and tried with several clips & projects (including the depthkit example) but cannot get the clip to playback in the Timeline (animation track), and therefore cannot record. I can see the animation play when I press “Play” on the top of Unity, but it doesn’t play in the timeline.

Any idea what I could be missing? Have tried going through a lot of documentation but am coming up empty (Unity n00b) so appreciate any guidance here!

I’m on Unity version 2019.4.16f1

Attached is a screenshot of how the gameobject is set up


@AlexP Have you tried Unity’s free Default Playables?

If using the Unity video player with the Default Playables, you can follow these steps.

  1. Right click in the Timeline window and select Activation Track.

  2. Assign your Depthkit Clip to the Activation Track.

  3. Right click in the Timeline again and select Video Script Playable Track.

  4. Select this new track, right click, and select Add From Video Player. Select your Depthkit clip.

  5. Select the video player track and see the Inspector. Assign the video clip from your Depthkit clip, as seen in the Inspector under Video Script Playable Asset. Set your preload time to three seconds. The Depthkit clips needs a few seconds to warm up when playing on the timeline. As a result, you will want to set your activation track to start 3 seconds prior to the start of your actual video clip.

With these steps, you should be all set to play your Depthkit clip on the Timeline. :partying_face:

A few pro tips:

  • Ensure your Depthkit clip poster image is disabled under Advanced Settings.
  • Ensure your Activation Track is set to start 3 seconds before the Video Script Playable Asset.
  • Set the Timeline playhead to the start of the Activation Track and scrub into the clip. This will allow the clip to “warm up” and can be a helpful trick if you are not having successful scrubbing.