Has anyone tried Depthkit on Magic Leap?

external-tools

(Roni T.) #1

I’m curious if anyone can share results!


(Alexander Porter) #2

I know that the team at Magic Leap has tried it and they reported finding it really compelling, but I haven’t seen it used yet in the wild.


(Chaitanya Shah) #3

Hi Peeps,

I tried importing a previous ARKit project into the magic leap.
Project Link: http://www.jovrnalism.io/2018/01/15/johnnies-house-innovation-in-immersive-storytelling/

Project Experience:

  • The experience starts with DepthKit capture of Johnnie, introducing himself and inviting the user to enter the portal.
  • Entering portal will take you outside his home in Leimert Park, a controversial neighborhood in LA.
  • There Johnnie will reappear telling his story.

As the experience is heavily dependent on Portal kind of experience, which in simple terms a transition from AR to VR, didn’t perform well on the Magic Leap headset. Though, we tried to fail and got some interesting understanding of the use of DepthKit in Magic Leap.

Attached some screen capture from Magic Leap:

Some Learning:

  • Magic Leap Display will render black as transparent. So beware with the use of black/dark colors.
  • Bright colors like favorable. So if possible, fill your wardrobe with bright colors.
  • You might be able to see that background is easily visible through the capture. The real environment is something we can not control, but one of the possible ways around that was discussed was to use of virtual objects placed at distant which can block those visuals. Not yet implemented.
  • Also, human scale design is hard because of FOV and clipping. For Magic Leap implementation, design the story of experience which can be viewed from a distance and not getting close to the capture. Maybe, start with a tabletop experience, and then move it further to a room scale.

Capture Details: It was captured through the previous version of Depthkit v0.2.0, and unity plugin used is also the legacy plugin and not the new one. I was getting some error with the new plugin and so used the previous one. I might be looking into solving that error.
Screen Capture Link: https://drive.google.com/file/d/1ueV-Wf7UaGGha-94RMfld19tgKDvNA2e/view?usp=sharing

All the best with creations,
Chait


(Chaitanya Shah) #4

Here is another image.