Kinect for Windows 2 sensor/ camera keeps disconnecting

Hi there

I am a complete noob with VolCap. I have a licence for Depthkit Core and am trying to set up my Kinect for Windows 2 sensor. The sensor keeps disconnecting. It works for a few seconds and then disconnects. I have tried using different ports on my laptop, but that is about it. Please see the image below:

Thank you for your help!

@MarindaBotha Welcome! Sorry to hear you’re experiencing this issue. I’ll share this with our technical team, but in my experience, an unstable connection is usually either due to:

  • insufficient power
  • or an incompatible data connection via the USB port.

Have you followed the Kinect v2 compatibility and intermittent connection (1)(2) sections of our documentation?

Does the Kinect Configuration Verifier tool reveal anything? Let us know, and we’ll do our best to help you narrow down the cause of the issue. Thanks!

Hello CoryAllen

Thanks very much for the quick response and information. I have worked through the documentation you suggested but the issue still persists. I use USB 3 ports, the newest driver is installed, sensor is plugged in straight to my house’s main power supply, I checked the performance of my system, nothing is draining power.

The Kinect Configuration Verifier tool does reveal that there is still a USB port issue, but it also states “Update configuration Definitions … using last known good definitions”. I’m not the most tech-savvy person, so perhaps the solution is quite simple. Please see the screenshot attached. Thank you for your help.

@MarindaBotha Thanks for sharing the screenshot. It looks like the Kinect may be plugged into an incompatible USB port. Have you tried any other USB ports on the computer? Do they all produce the same message in the Kv2 Configuration Verifier?

Have you also tried uninstalling and reinstalling the Kinect for Windows SDK?

Hi @CoryAllen

Yes, yes and yes.

Just as a side note, I was part of a cohort of African artists who recently received a sponsorship of these sensors from Depthkit. I checked with the cohort and 3 out of the 8 persons experience this issue I am describing.

Thank you for your help.

Agree - I’ve had this USB port issue a few times. Check your port is compatible with the Kinect v2. Saying that - I’ve found the Kinect V2 to be really unstable and often drops out even with a suitable port. Kinect Azure is definitely more relaible

@MarindaBotha Can you confirm the name of the USB Host Controllers behind the ports on your computer? You can find the name of your USB Host Controller in Windows Device Manager by following this section of our Sensor Connection troubleshooting documentation. These should either be Intel or Renesas controllers (per Microsoft’s documentation). If the chipsets of all of the USB ports are incompatible with the Kinect v2, you’ll need to use a different computer.

@MarindaBotha Checking in on this - Were you able to find a compatible USB port or computer to use with the Kinect?

Here’s something I’d forgotten but this did fix this issue for me the other day…

On your PC, open Device manager, at the bottom of the list you’ll see USB controllers. Right click the USB Port you’re using (I just applied this to all of them), click Properties, Power Management and untick “Allow the computer to turn off this device to save power”. This worked for me on Windows 10.