Nothing happens when trying to run depthkit installer

Nothing happens at all when trying to run intaller

Windows 10 Pro N (10.0.19044 )
Intel I7-8700
Nvidia RTX 3090

Have tried with both
depthkit 0.6.0-11
depthkit 0.5.12-0

Please help as I need this for an urgent project!

Cheers
Harvey

Hi, @HarveyMcGarry . I’d like to get some more information to try to narrow down the issue.

  • Are there any other applications/processes open when trying to run the installer?
  • Does anything appear on screen at all?
  • Does this change after restarting the computer?

Let us know, and we’ll guide you accordingly.

Hey Cory, thanks for getting back to me

Tried this through several restart cycles yeah

No other programs running

I click to run the installer and a blue loading circle flashes on the mouse and then nothing ( nothing appears in task manager ether )

Have tried running as administrator, fixing exe relations in registry and compatibility mode to no avail

No issues with anti virus or any blocking there, still won’t run with windows defender or uac off too

Kinda at a loss what to try next!

Cheers

Hi @HarveyMcGarry
Any chance you have access to an alternative PC to see if the behavior is the same, just for testing purposes?

We have not encountered installers not running before so this one has us stumped too.

Runs on my laptop just fine, similar other software installed as my PC

The urgency was because I had spilled a mug of coffee over my laptop on friday and so was out of action while I dried it out!
(Luckily thats fine now)
(Lenovo Legion 5 5500h RTX3070 Windows 10)

I have Kineckt 2 Windows SDK installed on my PC and not on my laptop, thats the only differnce I could imagine.

Really have tried everything I could think of too, its very strange behaviour

Like the first time I try to run the installer (ether of the two versions) after a boot I get one second of blue wheel mouse and then nothing happens, any time I try to run it after that, that doesnt even happen

hi @HarveyMcGarry

Discussing with our engineering team, we are suspicious that it’s Windows ‘N’ Edition, which seems to not come with any of the Media Foundation components needed for Depthkit’s internal video subsystem

From Microsoft:

*Third-party applications will be needed for video and music playback. Video chat and instant messaging will require a third-party application. The “N” editions of Windows 10 Home and Windows 10 Pro include the same functionality as the standard edition, except that they do not include certain media related technologies (Windows Media Player, Camera, Music, Films & TV) and do not include the Skype app.

If that is the issue, how do I fix it on this build?

Hey Please advise on next step, thank you!

@HarveyMcGarry, perhaps try adding the Media Feature Pack to that version of Windows to see if that loads the required dependencies.