Recommended drivers NVidia, Startech - 2022.04.02

Could someone recommend currently working drivers for the Nvidia A4000 and Startech USB cards please. We’re using the default Microsoft drivers for the Startech Driver Version: 10.0.19041.1566 and have tried several versions of the NVidia drivers with mixed results and frame drop errors. I’m going to post a more detailed breakdown soon.

1 Like

Hi @BernieWempe

Sorry to hear you are dropping frames on capture. Could you share a few more details about your camera and hardware configuration to ensure there aren’t other contributing factrors?

  • How many Sensors?
  • Color resolution for each camera that is configured in Depthkit
  • CPU
  • Motherboard

Can you also ensure that all of your sensors are on the latest and matching Azure Kinect Firmware?

For the Drivers, we recommend ensuring the latest drivers are installed from the manufacturers. Once we see the other system component we can better assess if drivers are the culprit.

Looking forward to getting your captures smoothly running!

Thanks James,

Here are the specs:

10 Azures but only using 9 now which prevents lockups and crashes.
RGB camera 1.6.110, depth sensor 1.6.79
(rollback? Some newer Azures came with depth sensor 1.6.80 but the latest firmware download was 1.6.79, RGB camera firmware stayed the same)

Cable Matters 5M Active USB 3.0 Extension Cable ‎200010-5 (same as recommended but shorter) Tried with 5v 2A ac adapters and without. Also tried without extenders, same errors.

i9-12900K 3.19 GHz
Asus Prim Z690-P D4
96 GB DDR4 3600mhz ram
StarTech PEXUSB3S44V x 2 (3rd card may be causing issues so took it out for now)
Microsft driver Version: 10.0.19041.1566
Nvidia A4000 latest driver date 2022-03-17 version

Unplugging sensors and uninstalling hidden devices Azures when the connections don’t show up. This seems to happen if sensors are unplugged plugged back in.

Regardless of how many sensors are connected we get these continuous streaming errors, set to color 720P Depth 640x576.

2022-04-03 14:28:33.309 ERROR [13508] [Depthkit::DepthSensorStage::onSensorEvent@295] Depth frame dropped. Delta: 10633322
2022-04-03 14:28:33.307 ERROR [13692] [Depthkit::DepthSensorStage::onSensorEvent@311] Infrared frame dropped. Delta: 10600000
2022-04-03 14:28:33.310 ERROR [7488] [Depthkit::DepthSensorStage::onSensorEvent@300] Color frame dropped. Delta: 66667
2022-04-03 14:28:33.311 ERROR [13652] [Depthkit::DepthSensorStage::onSensorEvent@295] Depth frame dropped. Delta: 10633322

Thanks for any help!

Hi @BernieWempe

Thanks for posting the detailed specs. I think I see what may be the issue here -

These console errors can be safely ignored usually, please refer to our Performance Diagnostics documentation to understand how to watch for critical dropped frames during recording. Let me know if the recording diagnostics panel is also showing dropped frames during capture, and if so we can continue to diagnose

Thanks James, we are getting glitches breakups in 2 or 3 sensor streams. Recordings are about 5 - 10 seconds long. Will report back with the diagnostics.

@BernieWempe If you’re capturing 10 sensors, and only using 2x StarTech PCIe cards, the reason the 9th and 10th sensors are dropping frames may be because of the USB ports they are plugged into. Do these ports have compatible chipsets? Do they share one controller? - This may be causing a bottleneck.

1 Like

Thanks Cory, we are using 3 cards and have managed to get all 10 sensors to work most of the time.