[RESOLVED] Depthkit not running on AMD processor

@Yonatan , @user2 , and @MartnD , I am parsing out the AMD issue from this thread to its own thread here:

another issue we got is that we couldn’t run depthkit on a computer with AMD processor - it resulted a broken image form the Kinect and run the software leggily (photo attached). used an Intel based pc and it worked. are you familiar with this issue? can it be solved somehow

we used:
AMD Ryzen 7 5800X 8-core
RTX 3090
CPU Driver version: NVIDIA 526.98
Azure SDK: 1.4.1
depthkit info

@Yonatan can you confirm the following:

  • Does this artifact still appear when the sensor is set to different color stream resolutions (720p, 1080p, 1440p, 2160p), or is it specific to only one/some of them?
  • Does this artifact appear whether or not you have GPU-accelerated video encoder selected in Depthkit’s preferences?
  • Can you confirm the type of USB controller that the Azure Kinect is plugged into? You can do this by opening Windows Device Manager, under Cameras selecting your Azure Kinect, then clicking View > ‘Devices by connection’ to see the connection heirarchy like the screenshot below. AMD computers typically have ASMedia USB controllers onboard, which are incompatible with the Azure Kinect, so we recommend using a compatible port on the motherboard, or if one isn’t available, a verified PCIe USB expansion card.

Thanks Cory,
changed the USB port to the motherboard and now it works!
the artifact did accure beforhand mostly on higher resolution - setting depth to 1024 or color higher than 1440.
now it seems to be working smoothly in any resolution.

@Yonatan Glad to hear it!