[RESOLVED] Issues with cleanly opening a Unity Project that uses Unity Depthkit Core Expansion Phase 8

I have a Unity Project that has these hard-coded paths to a Unity Depthkit Core Expansion (Phase 8)

I’m able to download them with a Phase 9 download by re-configuring those paths appropriately for my machine.
Side Note : I can’t seem to do the same with a Phase 10 download because there is no depthkit.core.vfx or depthkit.studio.vfx folders there.

By re-configuring those manifest.json paths I’m able to open the Unity Project but… the videos placed in the Video Player > Video Clip are no longer accepted and an errors like the one below gets output in the console :

indowsVideoMedia error 0xc00d5212 while reading Z:/Storage/Pariah/Unity/movie_section3_take10_F.21/movie_section3_take10_F.21_#4_proxy.mp4

Context: Setting media type for first video stream
Error details: No suitable transform was found to encode or decode the content.
Track types:
   Video Track [4496 x 2712], type: HEVC
      Resolution exceeds the Microsoft Media Foundation  decoder limit of 4096 x 2304 on Windows 10 and above.
      Install HEVC Video Extensions to enable HEVC format support on compatible devices.

So my question is - how can I open this project so that the videos work? Is it as simple as using Phase 8 of the Depthkit Core Expansion?

@PrashastThapan - Thanks for all of this information, and apologies that you’re running into these issues. There seem to be a couple occurring simultaneously:

  • Which version of Unity are you using? With the release of Phase 10 for Unity 2022, we fixed an incompatibility in earlier versions with the naming scheme of the Visual Effects packages and newer versions of Unity. For Unity 2022, you can manually remove the Depthkit packages from the project in Unity’s Package Manager, then reinstall the Phase 10 versions available for download on the Depthkit website. You will likely need to update the Depthkit components in your game objects after the new packages are loaded.
  • It looks from the error message you shared that the version of Windows you are using does not support playback of HEVC/H.265. See the Advanced Settings in Depthkit Core Exports to re-export your Depthkit assets in AVC/H.264 format, or add the HEVC Video Extension for Windows (This will enable HEVC/H.265 playback on your computer, but will not guarantee compatibility for playback on other PC’s).

We have just published a guide for the sample Unity projects available for download from the Depthkit website. This guide and the projects it describes may be useful references to you as you troubleshoot. Let us know if you have any further information, and we’ll go from there.

@PrashastThapan Were you able to resolve the Depthkit asset video playback issues you mentioned above? If so, let me know what the solution was, and I’ll close the ticket.

Hi Cory, yes I was able to resolve my issue by re-exporting my Depthkit clips. Thank you for your help!

1 Like