[RESOLVED] 'Empty' obj sequence meshes

We made a capture using only the Kinect sensor. The mp4 export works fine, but when exporting to an obj sequence the meshes seem broken. When importing the object in Blender you can see that the faces and verts are present, but they seem to be collapsed into a singularity :slight_smile:
We tried it with and without refinement masks.

Edit: We tried the same project, with a new capture on another PC but the same problem persists.

1 Like

@GlennWustlich - To diagnose, please send us the following:

  • The Depthkit project (complete with project JSON and the take folder of the affected clip)
  • Examples of the OBJ’s displaying this issue.
  • Any other context around export settings or the project (e.g. Does this behavior only happen when a Cinema clip is applied to the clip? Does this issue only appear in some of the OBJ’s in the exported sequence or all of them?)

@GlennWustlich Thanks for sharing the corrupted OBJ with us. If you open the OBJ in a text editor, you can see that all of the coordinates have commas instead of periods to represent decimals. We are investigating to figure out the cause of this, but it is likely that Depthkit’s OBJ exporter publishes an incorrect format when Windows is set to a localization which uses commas.

We will address this in the next Depthkit version, but in the meantime, the OBJ’s can be recovered by converting all commas to periods.

You can also try switching your Windows localization settings to a format which uses periods to represent decimals and try re-exporting the OBJ’s.

1 Like

Hello, I have the same problem and the “solution” works.
(Spanish region)

BlockquoteYou can also try changing your Windows localization settings to a format that uses dots to represent decimals and try re-exporting the OBJs.

In Windows you can change the comma of the dot in “region” → Additional information.

Please fix this bug as soon as possible <3

Hola, tengo el mismo problema y la “solución” funciona.
(region española)

BlockquoteTambién puedes intentar cambiar la configuración de localización de Windows a un formato que utilice puntos para representar decimales e intentar reexportar los OBJ.

En Windows puede cambiar en “región” → Información adicional la coma del punto.

Por favor, solucionar este bug lo antes posible <3

@AdrianMantilla Thank you for confirming the nature of this issue and the workaround. I have escalated this with our development team, and will let you know when you can expect an update which addresses this.

Same problem here, i´m from Chile. I´m trying to change my location…

Hola Adrián, cómo lo solucionaste?
Pruebo cambiar la ubicación predeterminada seleccionado USA en el mapa. Pero luego al exportar en DepthKit me siguen apareciendo los OBJ con comas.

@aldomanetti We have addressed this in Depthkit version 0.8.1, which will be released shortly.

@GlennWustlich @AdrianMantilla @aldomanetti - Depthkit version 0.8.1 has just been released, and addresses the issue of corrupted OBJ sequence exports, and provides many more options for mesh export like PLY & Draco files, as well as more intelligent mesh simplification. More details are available in our Release Notes.

I did some tests with the new version but it still gives me the format with ", "
Even having the region in the United States.

It is possible to download the previous version because I have to move forward in the project. Thanks

I attached a screenshot

@aldomanetti Thank you for flagging this. We are investigating. To help narrow this down, does this issue still occur when you have ‘Regional format’ / ‘Formato regional’ also set to "United States’ / ‘Estados Unidos’ rather than ‘Recommended’ / ‘Recomendaciones’?

I changed everything I could to the United States and now it added the periods instead of the commas.
Thanks, with this I can continue moving forward

@aldomanetti Glad to hear this workaround has unblocked you. We believe we have identified the issue, and will include the proper fix in the next update.

@aldomanetti We have just pushed the latest patch (0.8.1-7 #82ca) which should fully address this issue while allowing you to keep your computer’s regional settings to those for your country/region. Depthkit will prompt you to update the next time you open it, or you can download the latest installer on the Depthkit website.