Shadow for the captured model

I’m working on a project that just captures the Kinect volumetric model and shows it on the scene. I’m trying to get a shadow of the model and I’ve tried different options and some dynamic plugins, but I don’t get anything.

My Unity version is 2020.3.14f1 and Depthkit Studio 6.11.

Does anybody know why it doesn’t work and what is the solution?



Javier Campos.

@JavierCampos Which render pipeline are you using in your Unity project? Can you share any screenshots or more information?

Hope it helps.



Hi, @JavierCampos. It looks like you’re using Unity’s Built-in Render Pipeline. Though the options for lighting and shadows are limited in this pipeline are limited compared to the scriptable render pipelines, there are still some controls which affect shadows.

First, ensure the appropriate Built-in Look component for the type of asset you are using is attached to your Depthkit object. If you have Depthkit Studio assets, use the Depthkit Studio Built-in Look.

By default, self-shadowing and casting shadows on other objects are enabled.

In the Depthkit object’s Built-in Look component, ensure that the Receive Shadows box is checked to enable self-shadowing.

For any other object that you want the Depthkit object to cast shadows on, make sure that that’s object’s Mesh Render component > Lighting > Receive Shadows box is checked.

Which platform/OS are you using Unity on, and which platform and hardware are the assets ultimately going to be shown on? Can you share any more context about what your larger goal is with these assets/tests?